PostgreSQL La base de donnees la plus sophistiquee au monde.

Forums PostgreSQL.fr

Le forum officiel de la communauté francophone de PostgreSQL

Vous n'êtes pas identifié(e).

#1 13/01/2021 11:27:09

albourg
Membre

version minimale postgresql.jar pour postgres 13

Bonjour,

je vais upgrader un postgres 10->postgres 13.
Les applis utilisent postgresql-42.2.5.jar.

Ce .jar est-il compatible avec postgres 13?
Si non, quelle version supporte postgres 13? Dans le changelog il est marqué https://jdbc.postgresql.org/documentati … gelog.html que le 42.2.6 ajoute du support pour postgres 11 et 12. Mais rien n'est mis pour le 13, pour aucune version.

Merci.

Hors ligne

#2 13/01/2021 12:42:38

gleu
Administrateur

Re : version minimale postgresql.jar pour postgres 13

Le site indique que "The current version of the driver should be compatible with PostgreSQL 8.2 and higher". Du coup, j'utiliserais plutôt la version la plus récente du driver (donc la 42.2.18). De plus, cette version est sortie après la version 13 de PostgreSQL, donc elle a bien plus de chance d'être compatible qu'une version qui date de 2018 (votre 42.2.5).


Guillaume.

En ligne

#3 13/01/2021 14:43:58

albourg
Membre

Re : version minimale postgresql.jar pour postgres 13

la question est surtout de savoir si une upgrade du driver est nécessaire, et à partir de quelle version.
"The current version of the driver should be compatible with PostgreSQL 8.2 and higher" veut dire que le driver doit se connecter à une db >=8.2, mais pas si le 42.2.5 est compatible avec postgres 13.

Hors ligne

#4 13/01/2021 16:32:56

gleu
Administrateur

Re : version minimale postgresql.jar pour postgres 13

Connaissant les développeurs de ce driver, je suis certain que leur dernière version est compatible avec PostgreSQL. Il est possible que la 42.2.5 le soit aussi, même si j'en doute (du fait des changements dans les catalogues systèmes PostgreSQL). Le meilleur moyen de s'en assurer est de leur demander sur leur liste de discussion. N'utilisant pas Java, je ne saurais pas aller plus loin.


Guillaume.

En ligne

#5 13/01/2021 16:42:58

albourg
Membre

Re : version minimale postgresql.jar pour postgres 13

Auriez-vous un lien vers leur liste de discussion où je peux leur poser la question?

Hors ligne

#6 13/01/2021 17:25:13

gleu
Administrateur

Re : version minimale postgresql.jar pour postgres 13


Guillaume.

En ligne

#7 13/01/2021 17:25:45

rjuju
Administrateur

Re : version minimale postgresql.jar pour postgres 13

Hors ligne

#8 13/01/2021 18:44:51

albourg
Membre

Re : version minimale postgresql.jar pour postgres 13

ca, ca permet de voir les liens. Si j'envoie la question à pgsql-jdbc@lists.postgresql.org, j'espère que ca ne va pas envoyer le messages au million d'abonnés?

Hors ligne

#9 13/01/2021 22:57:04

gleu
Administrateur

Re : version minimale postgresql.jar pour postgres 13

Bin, si. C'est un peu le principe d'une liste de discussions.


Guillaume.

En ligne

Pied de page des forums