PostgreSQL La base de donnees la plus sophistiquee au monde.

Forums PostgreSQL.fr

Le forum officiel de la communauté francophone de PostgreSQL

Vous n'êtes pas identifié(e).

#1 26/03/2020 20:00:45

Blocage de l'éditeur de requête Query tool

Bonjour,
J'ai installé sans souci PostgreSQL en version 12 avec son pgAdmin4 4.18, ceci sur un Windows Serveur 2008 R2.
J'ai pu créer logins, base, tablespace, schéma, table sans souci.
Par contre, impossible d'accéder à l'Editeur de requêtes, que ce soit par Tools/Query tool ou clic droit à partir de ma base.
Message : 127.0.0.1 ne répond pas Restaurer la page web.
Impossible de poursuivre sans cliquer sur Restaurer la page web qui m'oblige à fermer le programme.
En résumé l'accès à Query tool bloque toute l'interface.

J'ai trouvé un pb approchant pour pgAdmin3 qui date de 2011 et recommande de supprimer le fichier pgadmin_histoqueries.xml qui serait corrompu, mais je ne trouve pas ce fichier dans mon installation

Après 48h de tergiversations, j'appelle à l'aide.
Après de multiples essais, je viens à l'instant de parvenir à le lancer pour la première fois par clic droit sur la base... , une fois mais pas deux ! (j'ai refermé l'éditeur et impossible de le rouvrir). Le menu Query tool bloque toujours.

Une idée ?
Merci d'avance

Dernière modification par FleurDePoireau (26/03/2020 20:01:50)

Hors ligne

#2 27/03/2020 08:17:20

rjuju
Administrateur

Re : Blocage de l'éditeur de requête Query tool

Bonjour,


Malheureusement assez peu de personnes utilisent pgAdmin4 ici, et je ne l'utilise pas personnellement, donc difficile de vraiment aider.  Vous pouvez essayer de vider le cache de votre navigateur ou voir dans les outils de développement de votre navigateur si des erreurs apparaissent, mais le mieux serait probablement de contacter directement les développeurs : https://www.pgadmin.org/support/

Hors ligne

#3 27/03/2020 11:41:06

Re : Blocage de l'éditeur de requête Query tool

Bonjour, merci pour les conseils que j'ai suivis, sans résultat.
Je vais donc consulter le support et reviendrai donner des nouvelles.

Hors ligne

#4 27/03/2020 13:47:46

Re : Blocage de l'éditeur de requête Query tool

Salut
Pour le moment le rythme de sortie de pgadmin4 dépasse celui des packages offerts par les entreprises tierces.
Le mieux est donc d'éviter pgadmin4 lors de l'installation des packages et d'installer (et mettre à jour) pgadmin4 avec l'installeur proposé par pgadmin.org (actuellement à la version 4.19!)
@+

Hors ligne

#5 30/03/2020 22:44:47

Re : Blocage de l'éditeur de requête Query tool

Bonne nouvelle.

Après consultation du support, voici ma conclusion et la solution de contournement adoptée :
- pgAdmin4 n'est probablement pas complètement compatible avec mon vieil IE11, navigateur que j'utilisais couramment sur le serveur PostgreSQL. Je dis probablement car le Support ne me l'a pas dit explicitement...
- comme je faisais valoir que j'avais également testé sous Firefox (je pressentais un pb de navigateur...) et que c'était pire, que je ne pouvais même pas entrer dans pgAdmin4 (message Unauthorized
The server could not verify that you are authorized to access the URL requested. You either supplied the wrong credentials (e.g. a bad password), or your browser doesn't understand how to supply the credentials required.),
le Support a pu me débloquer de ce côté :
   . PostgreSQL étant lancé, ouverture de la fenêtre PostgreSQL dans la zone de notifications (en bas à droite de l'écran),
   . Sélection du choix Copy server URL,
   . Collage de cette URL dans Firefox, avec clé embarquée, ce qui n'était pas le cas quand je copiais simplement l'URL courante de IE11 vers Firefox...
L'accès pgAdmin4 puis à Query tool semblent dorénavant bien fonctionner.

Merci à tous et à chacun pour votre aide.

Hors ligne

#6 Hier 08:12:31

rjuju
Administrateur

Re : Blocage de l'éditeur de requête Query tool

Bonne nouvelle !

Hors ligne

Pied de page des forums