PostgreSQL La base de donnees la plus sophistiquee au monde.

Forums PostgreSQL.fr

Le forum officiel de la communauté francophone de PostgreSQL

Vous n'êtes pas identifié(e).

#1 27/11/2018 16:37:46

giak79
Membre

Oracle Data Integrator & PostgreSQL 9.6.10

Salut,

J'ai un autre problème: ODI génère l'erreur suivante lors de la lecture des données contenues dans la table PostgreSQL:

 
ODI-1227: Le telechargement de la tâche SrcSet0 échoue au niveau de la connexion PROD POSTGRESSQL.
Causé par l'exception: org.postgresql.util.PSQLException: ERREUR: la pile de pgaudit n'est pas vide.

( ODI-1227: Task SrcSet0 (Loading) fails on the source POSTGRESSQL connection STOREPICKING.
  Caused By: org.postgresql.util.PSQLException: ERROR: pgaudit stack is not empty )

 
Est-ce que quelqu'un peut m'aider ?

 
merci d'avance

postgreSQL Driver :  postgresql-42.2.5.jre6.jar

Oracle Data Integrator  : 11.1.1.1.6.0

DB PostgreSQL 9.6.10

Hors ligne

#2 28/11/2018 10:42:04

gleu
Administrateur

Re : Oracle Data Integrator & PostgreSQL 9.6.10

Il y a apparemment une incompatibilité entre ODI et l'extension pgaudit. Difficile d'en dire plus. Vérifiez que vous avez la bonne version de pgaudit pour votre version de PostgreSQL, mettez à jour PostgreSQL dans sa dernière version (9.6.11). En dehors de ça, ne connaissant pas ODI...

Hors ligne

#3 28/11/2018 13:03:55

giak79
Membre

Re : Oracle Data Integrator & PostgreSQL 9.6.10

merci pour la réponse.

La version de pgaudit pgAudit v1.1.X va bien avec 9.6.11 ?

Ou la dernière version v1.3.X est-elle meilleure?

Hors ligne

#4 28/11/2018 17:49:23

dverite
Membre

Re : Oracle Data Integrator & PostgreSQL 9.6.10

D'après https://github.com/pgaudit/pgaudit/releases:
  "For PG 9.6 needs, please use release series 1.1.X."

A vue d'oeil le " pgaudit stack is not empty " ressemble à une erreur interne de pgaudit qui ne devrait pas arriver, ça peut valoir le coup de faire un rapport de bug pour avoir un retour des développeurs de l'extension.

Hors ligne

#5 06/12/2018 18:33:22

giak79
Membre

Re : Oracle Data Integrator & PostgreSQL 9.6.10

si désactivé PGAUDIT, fonctionne correctement

Hors ligne

Pied de page des forums