PostgreSQL La base de donnees la plus sophistiquee au monde.

Forums PostgreSQL.fr

Le forum officiel de la communauté francophone de PostgreSQL

Vous n'êtes pas identifié(e).

#1 30/11/2018 12:59:25

trainvapeur
Membre

postgre10 et RED HAT7

rebonjour,

mon client a un gros souci je vous le transmet !
Il voudrait installer postgre10.6 sur RED HAT 7 parce que c'est le Linux qu'ils maitrisent le mieux (ils font plein de VM). Mais Le support Redhat 7 ne supporte Postgre que pour la version 9.x. Ce client a lui même des clients dans le monde entier et mon travail est de lui permettre de stocker ses données sur une période beaucoup plus longue : on passerait de 3 mois à 5 ans et la base passerait de 50 go à 500 go.


1°) y-a-t-il des problèmes répertoriés avec Postgre 10 et RedHat 7 ? S'engage-t-on vers des difficultés ? On va partitionner des tables et on utilise beaucoup oracle_fdw.

2°) y-a-t-il une autre distribution Linux recommandée pour Postgre 10 ?

Et j'ajoute, parce que je pense qu'on va y arriver bientôt, et pour postgre 11 ?

Cordialement,
Jean

Hors ligne

#2 30/11/2018 15:06:14

gleu
Administrateur

Re : postgre10 et RED HAT7

Pas de problème connu entre PostgreSQL et RedHat, quelque soit leur version. Le mieux est d'utiliser un dépôt de la communauté (sur yum.postgresql.org).

Hors ligne

#3 30/11/2018 15:13:40

ruizsebastien
Membre

Re : postgre10 et RED HAT7

Bonjour,

Le problème avec redhat7 c'est la mise à jour des dépôts (je suis confronté au problème aussi en ce moment).
Pour avoir la version PG v10, les paquets ne sont pas dans les dépôts officiels.
Il faut installer un dépôt "additionnel" qui installe les paquets postgresql v10 sous cette forme :
rh-postgresql10-postgresql.x86_64 : PostgreSQL client programs
rh-postgresql10-postgresql-contrib.x86_64 : Extension modules distributed with PostgreSQL
rh-postgresql10-postgresql-devel.x86_64 : PostgreSQL development header files and libraries
rh-postgresql10-postgresql-docs.x86_64 : Extra documentation for PostgreSQL
rh-postgresql10-postgresql-libs.x86_64 : The shared libraries required for any PostgreSQL clients
rh-postgresql10-postgresql-plperl.x86_64 : The Perl procedural language for PostgreSQL
rh-postgresql10-postgresql-plpython.x86_64 : The Python2 procedural language for PostgreSQL
rh-postgresql10-postgresql-pltcl.x86_64 : The Tcl procedural language for PostgreSQL
rh-postgresql10-postgresql-server.x86_64 : The programs needed to create and run a PostgreSQL server
etc...

Les paquets rh-... sont très bien au niveau du moteur PG, le moteur est identique et conforme.
Par contre ils ne s'installent pas à l'endroit prévu :
/opt/rh/rh-postgresql10/root/usr/
au lieu de
/usr/pgsql-10/

et on ne peut pas utiliser systemd pour l'arrêt/relance de l'instance au reboot du serveur.
Bref dans mon cas je ne vais pas installer pg v10 en production en l'état :
- sauf si d'ici là les paquets sont publier dans les dépôts officiels (personne chez redhat ne peux nous dire quand)
- sauf si on décide d'installer un dépôt satellite en lien avec :
https://yum.postgresql.org/repopackages.php#pg10
- utiliser une centOs7

A part ça aucun problème à utiliser postgreSQL v10 avec redhat. Et pourquoi pas la v11 (si vous avez le choix, autant partir sur la plus récente.)


Cordialement,

Sébastien.

Hors ligne

#4 30/11/2018 19:00:29

pitpoule
Membre

Re : postgre10 et RED HAT7

Je ne vois pas bien votre problème de systemd. J'ai installé la version 9.5 avec les dépôts RHSCL et je n'ai pas eu de problème d'arrêt/démarrage automatique (bon ,c'était il y a plus de deux ans...).

Le problème que vous pouvez rencontrez, c'est que les lib sont aussi sous /opt.... il faut parfois initialiser un LIBRARY_PATH au niveau du profil de l'utilisateur postgres

Hors ligne

#5 01/12/2018 00:48:31

rjuju
Administrateur

Re : postgre10 et RED HAT7

Je vous recommande grandement de passer par les dépots de yum.postgresql.org.  Vous avez de la documentation disponible: https://yum.postgresql.org/howtoyum.php


Par exemple pour systemd: https://people.planetpostgresql.org/dev … HEL-7.html  vous n'avez qu'à adapter pour la version que vous souhaitez.

Hors ligne

#6 03/12/2018 09:37:23

ruizsebastien
Membre

Re : postgre10 et RED HAT7

pitpoule a écrit :

Je ne vois pas bien votre problème de systemd. J'ai installé la version 9.5 avec les dépôts RHSCL et je n'ai pas eu de problème d'arrêt/démarrage automatique (bon ,c'était il y a plus de deux ans...).

Le problème que vous pouvez rencontrez, c'est que les lib sont aussi sous /opt.... il faut parfois initialiser un LIBRARY_PATH au niveau du profil de l'utilisateur postgres

Le problème c'est que quand on est dans une logique d'industrialisation, on souhaite avoir les installations identiques partout et quelque soit la version du moteur.
Alors effectivement en changeant les variables d'environnement systemd fonctionne...mais ce n'est pas standard.

Comme dit rjuju il vaut mieux passer par les dépôts yum.postgresql.org que par ceux non conforme de redhat (rhscl).

Dernière modification par ruizsebastien (03/12/2018 09:37:48)


Cordialement,

Sébastien.

Hors ligne

#7 03/12/2018 11:17:06

pitpoule
Membre

Re : postgre10 et RED HAT7

ruizsebastien a écrit :

Le problème c'est que quand on est dans une logique d'industrialisation, on souhaite avoir les installations identiques partout et quelque soit la version du moteur.
Alors effectivement en changeant les variables d'environnement systemd fonctionne...mais ce n'est pas standard.

Comme dit rjuju il vaut mieux passer par les dépôts yum.postgresql.org que par ceux non conforme de redhat (rhscl).

Moi je vous répondais sur le problème de systemd par sur la problématique générale de l'industrialisation... Si  j'ai eu à installer du PG avec les paquets RHSCL, ce n'est pas par choix mais par obligation.... comme vous ;p . Pour certains entreprises, l’industrialisation , c'est de rester conforme au socle système et donc aux paquets fournis par redhat (je suppose pour une histoire de support) . De plus, il n'est souvent pas possible d'introduire des dépôts externes sur les environnements de production, d'où la difficulté d'utiliser les dépôts officiels PG.

Après utiliser PG depuis les dépôts RHSCL me parait un moindre mal par rapport à celui d'utiliser une version obsolète fournie de base en RH7 (9.2). Et l’industrialisation... je pense que ça doit pouvoir s'adapter quand même smile

Hors ligne

#8 03/12/2018 11:25:42

ruizsebastien
Membre

Re : postgre10 et RED HAT7

tout à fait d'accord ;-)
(dommage c'est pas toujours le DBA qui décide...)

Dernière modification par ruizsebastien (03/12/2018 11:26:32)


Cordialement,

Sébastien.

Hors ligne

Pied de page des forums