PostgreSQL La base de donnees la plus sophistiquee au monde.

Forums PostgreSQL.fr

Le forum officiel de la communauté francophone de PostgreSQL

Vous n'êtes pas identifié(e).

#1 20/06/2018 12:36:29

p.gillet
Membre

pgAdmin 4 v3.0 - template0

Bonjour à toutes et tous,

je viens d'installer une mise à jour de postgres en version 9.6.9 et lors de l'install il m'a aussi installé pgAdmin 4 v3.0.
Le problème c'est que dans cette version, si je veux créer une nouvelle base, on ne trouve plus les template0 et template1.
Résultat je ne peux créer que des bases en UTF8 car pour du Win1252 il me faut le template0.

Quelqu'un à-t-il déjà eu ce soucis ?
En fait j'ai refait 2 fois mon install en me disant que j'avais dû louper un truc... mais non ! plus de template0.

Hors ligne

#2 20/06/2018 16:34:04

rjuju
Administrateur

Re : pgAdmin 4 v3.0 - template0

Aucune idée avec pgAdmin.  Mais en sql:

CREATE DATABASE nom ENCODING ... TEMPLATE template0;

Hors ligne

#3 20/06/2018 18:48:35

p.gillet
Membre

Re : pgAdmin 4 v3.0 - template0

Ok, je vais essayer çà - merci

Mais... il faut d'abord que je résolve un autre problème : < The application server could not be connected >
Encore un petit effort et je crois que je vais retrouver avec postgres ce qui m'a fait fuir Oracle... çà marche, on sait pas pourquoi, çà marche pas... pareil !
Allez, courage ! Je m'y remets.

Hors ligne

#4 21/06/2018 00:01:38

rjuju
Administrateur

Re : pgAdmin 4 v3.0 - template0

C'est à priori un message d'erreur de pgadmin4, pas de postgres.

Hors ligne

#5 22/06/2018 11:17:48

gleu
Administrateur

Re : pgAdmin 4 v3.0 - template0

Par défaut, les bases template ne sont pas affichées par pgadmin. Ça ne veut pas dire pour autant qu'elles n'existent pas.

Hors ligne

Pied de page des forums