PostgreSQL La base de donnees la plus sophistiquee au monde.

Forums PostgreSQL.fr

Le forum officiel de la communauté francophone de PostgreSQL

Vous n'êtes pas identifié(e).

#1 16/01/2019 11:27:48

Moige
Membre

Installeur du serveur v8.4? | Reset du mdp superuser?

Bonjour,

Mon travail attend de moi que je traite une base postgres créée en version 8.4, mais le seul serveur auquel j'aie accès est en version 11.
Tenter de lancer la base fait se bloquer le serveur, qui m'indique que les versions sont incompatibles.
Les options que j'ai trouvé sont;
-Demander un dump de la base plutôt que le dossier data.
-Utiliser pg_upgrade.
Demander un dump est sûr de faire reculer mon interlocuteur, et va bloquer le dossier.
Utiliser pg_upgrade nécessite une installation en version 8.4.
J'ai cherché un installeur mais ils ne semblent plus distribués sur un site officiel, et des sites de vieilles versions me donnent des installeurs qui demandent un mot de passe superuser spécifique que je ne connaît pas.

J'aurai besoin de directions vers une version de l'installeur qui me laisse définir ce mot de passe.

Il est aussi possible que ce mot de passe ait bien été saisi par un de mes prédécesseurs, mais je n'ai aucune façon de le connaître.
Dans ce cas plutôt qu'un installeur, j'aurai besoin d'aide pour comprendre comment faire pour reset ce mot de passe et pouvoir faire une installation clean.


Merci d'avance.

Hors ligne

#2 16/01/2019 17:22:23

gleu
Administrateur

Re : Installeur du serveur v8.4? | Reset du mdp superuser?

Vous feriez mieux de demander un dump, ce serait beaucoup plus simple.

Si vous voulez continuer avec le répertoire data, je suppose qu'il contient les journaux de transactions et que l'installation originale n'avait pas de tablespaces (sinon il faut aussi récupérer tout ça). Vous devez réinstaller ce répertoire data sur un serveur de même architecture matérielle (par exemple 32bits si c'était du 32 bits ou 64bits si c'était du 64 bits) et logicielle (ne pas restaurer le répertoire 8.4 d'un serveur PostgreSQL sous Windows sur un serveur PostgreSQL sous Unix, ça ne fonctionnera pas).

Quant à votre installeur, duquel s'agit-il ? les installeurs les plus connus sont ceux d'EntrepriseDB et ils demandent un mot de passe pour le configurer, pas pour le vérifier.

Hors ligne

#3 16/01/2019 17:39:55

Moige
Membre

Re : Installeur du serveur v8.4? | Reset du mdp superuser?

TLDR: J'ai fait un pg_dump.

@gleu
Tout d'abord merci pour votre réponse.
L'architecture n'est pas un problème (W32 vers W32).
J'utilisais un installeur de oldapps.com, dans le doute j'ai essayé celui de EntrepriseDB et pareil il me demande de saisir un mot de passe puis m'annonce qu'il est incorrect (quoi que je rentre).
C'est probablement du à une vielle installation mal nettoyée, et je n'ai pas la moindre idée de comment virer ce vieux mdp.
La difficulté ici d'obtenir un dump est que je passe par un revendeur pas calé en informatique et que le client ne gère pas sa base directement mais à travers un logiciel dont l'éditeur refuserait vraisemblablement de fournir les identifiants qu'il utilise, et fait payer un export officiel.

Le problème est maintenant résolu; l'éditeur adverse utilise différents types de BDD, et a quelques difficultés à sécuriser certaines d'entre elles. Je suis intervenu directement sur le poste du client et ai utilisé les mêmes identifiants pour postgres qu'ils utilisent pour oracle, et magie magie après quelques dizaines de minutes à tatonner dans le noir j'ai pu prendre la main sur la base du client et y brancher pg_dump, créer mon fichier d'export, et le rapatrier.

Hors ligne

Pied de page des forums