PostgreSQL La base de donnees la plus sophistiquee au monde.

Forums PostgreSQL.fr

Le forum officiel de la communauté francophone de PostgreSQL

Vous n'êtes pas identifié(e).

#1 27/01/2017 11:07:49

mortimer.pw
Membre

Tail & Mail problème LOG_LINE_PREFIX

Bonjour,

Je travaille avec un moteur 9.2.3 sous Cent-OS 6.

J'essaye de mettre en place Tail & Mail pour remonter des alertes.

Cela fonctionne, sauf quand je veux indiquer dans le tnm.config.txt, la valeur  LOG_LINE_PREFIX: '%t [%p]: [%l-1] user=%u %h %s '

Si cela peut aider, exemple de ligne de mon fichier de trace :
2017-01-27 10:51:00 CET [26578]: [4-1] user=postgres [local] 2017-01-27 10:51:00 CET LOG:  disconnection: session time: 0:00:00.014 user=postgres database=postgres host=[local]

Avez-vous une idée ?

D'avance merci.

Dernière modification par mortimer.pw (27/01/2017 11:11:47)

Hors ligne

#2 27/01/2017 18:23:13

gleu
Administrateur

Re : Tail & Mail problème LOG_LINE_PREFIX

Peut-être qu'indiquer de quel outil vous parlez (une URL vers le site web peut être ?), le fichier de configuration et la ligne de commande exécutée pourrait aider à comprendre ce dont vous parlez. Parce que là, moi, aucune idée...

Hors ligne

#3 30/01/2017 11:39:13

mortimer.pw
Membre

Re : Tail & Mail problème LOG_LINE_PREFIX

Bonjour Guillaume,

J'ai téléchargé les deux fichiers, tail_n_mail et tail_n_mail.asc, à l'URL : https://bucardo.org/wiki/Tail_n_mail
Puis copié les copier dans /home/postgres/scripts et les aient rendu exécutable.

J'ai exécuté la commande suivante pour créer le fichier de configuration :
    tail tail_n_mail > tnm.config.txt

J'ai modifié le fichier de configuration pour indiquer :
    EMAIL:
    MAILSUBJECT:
    FILE:
    INCLUDE: WARNING: pour avoir les anomalies d'écriture des WAL archivés par Pitrery (ARCHIVE_OVERWRITE="no")
        LOG_LINE_PREFIX: '%t [%p]: [%l-1] user=%u %h %s '

J'ai mis en Crontab
    # TnM PostgreSQL ALERTE
    */2 * * * * perl /home/postgres/scripts/tail_n_mail /home/postgres/scripts/tnm.config.txt

Voilà toutes les infos, merci pour votre aide.

Hors ligne

#4 30/01/2017 22:29:23

gleu
Administrateur

Re : Tail & Mail problème LOG_LINE_PREFIX

Que fait l'outil quand vous l'exécutez manuellement ?

Hors ligne

#5 31/01/2017 09:09:11

mortimer.pw
Membre

Re : Tail & Mail problème LOG_LINE_PREFIX

Bonjour Guillaume,

Tout d'abord, j'ai dit une bêtise, j'ai indiqué mon log_line_prefix, non pas dans mon /home/postgres/scripts/tnm.config.txt, mais dans le /home/postgres/.tailnmailrc (à la racine de mon user).

Sans ce fichier /home/postgres/.tailnmailrc, j'exécute les commandes ci-dessous, je reçois un  mail.

[postgres@dev-bdd-01 ~]$ psql geo
psql.bin (9.5.1)
Type "help" for help.

geo=# select * from titi;
ERROR:  relation "titi" does not exist
LINE 1: select * from titi;
                      ^
geo=# \q
[postgres@dev-bdd-01 ~]$ perl /home/postgres/scripts/tail_n_mail /home/postgres/scripts/tnm.config.txt

Avec ce fichier, je ne reçois plus de mail.

Hors ligne

#6 31/01/2017 13:20:09

arthurr
Membre

Re : Tail & Mail problème LOG_LINE_PREFIX

J'ai déjà eu le problème, pour moi il faut supprimer le dernier espace dans votre .tailnmailrc pour avoir :

LOG_LINE_PREFIX = '%t [%p]: [%l-1] user=%u %h %s'

Hors ligne

#7 31/01/2017 14:13:10

mortimer.pw
Membre

Re : Tail & Mail problème LOG_LINE_PREFIX

Bonjour Arthurr,
Merci pour la participation, mais cela ne change rien :-(.

Hors ligne

#8 31/01/2017 17:04:31

arthurr
Membre

Re : Tail & Mail problème LOG_LINE_PREFIX

https://bucardo.org/wiki/Tail_n_mail#Debugging_options:

/usr/bin/perl /opt/tail_n_mail/tail_n_mail --dryrun --debug /opt/tail_n_mail/tnm.config.txt

Tu vas au moins voir si il récupère bien le log_line_prefix, c'est une première étape smile

Hors ligne

#9 01/02/2017 08:25:07

mortimer.pw
Membre

Re : Tail & Mail problème LOG_LINE_PREFIX

Bonjour Arthurr,
Ci-dessous le résultat de la commande :
[postgres@dev-indusbdd-01 ~]$ perl /home/postgres/scripts/tail_n_mail --dryrun --debug /home/postgres/scripts/tnm.config.txt
Opened config file "/home/postgres/scripts/tnm.config.txt"
$opt1 = {
          'email' => [
.....
.....
$arg1 = {
          'verbose' => 1,
          'log_line_prefix' => '\'%t [%p]: [%l-1] user=%u %h %s\'',
          'mailserver' => 'example.com',
.....
.....
        };
  Log line prefix regex: (?-xism:^((\d\d\d\d-\d\d-\d\d \d\d:\d\d:\d\d \w\w\w\w?) \[(\d+)\]: \[\d+\-1\] user=[\[\w\-\.\]]* \S* %s)(.*))
  Log line prefix regex2: (?-xism:^\d\d\d\d-\d\d-\d\d \d\d:\d\d:\d\d \w\w\w\w? \[\d+\]: \[\-1\] user=  )
  Log line prefix regex3: (?-xism:^\d\d\d\d-\d\d-\d\d \d\d:\d\d:\d\d \w\w\w\w?)
Parsing file: /home/postgres/pg_log/3-07.log
.....

Visiblement, oui il est récupéré.

Merci pour ton aide.

Hors ligne

#10 09/02/2017 10:42:58

mortimer.pw
Membre

Re : Tail & Mail problème LOG_LINE_PREFIX

Bonjour,
Personne n'a le problème ?
Merci.

Hors ligne

Pied de page des forums