PostgreSQL La base de donnees la plus sophistiquee au monde.

Forums PostgreSQL.fr

Le forum officiel de la communauté francophone de PostgreSQL

Vous n'êtes pas identifié(e).

#1 05/10/2016 20:06:31

abuche
Membre

[Resolu] Postgres 9.6 - Postgis

bonjour,

Après install dans /opt, je ne sais pas comment démarre le serveur
Je me connecte avec pgadmin IV et voudrai obtenir  un accès en mode console


sudo /etc/init.d/postgresql start
 * No PostgreSQL clusters exist; see "man pg_createcluster"

C'est postgis que je veux utiliser avec Qgis logiciel de cartographie
La déclaration de couche postgis ne trouve pas les bdd que j'ai créé avec pgmadmin
La connection login: postgres // pass : xxxx se plante dans Qgis

Merci de vos conseils et expériences

@+

Dernière modification par abuche (08/10/2016 13:28:32)

Hors ligne

#2 05/10/2016 20:11:37

rjuju
Administrateur

Re : [Resolu] Postgres 9.6 - Postgis

Vous pouvez vous connecter avec pgadmin4 mais pas en mode console ? L'instance postgres est-elle démarrée ?

Hors ligne

#3 05/10/2016 20:15:41

abuche
Membre

Re : [Resolu] Postgres 9.6 - Postgis

Merci de vos réponses
Proposer moi des vérifications
J'avais un postgres 9.3 qui était dans le dépot de ubuntu 14.04 et la connexion est active
J'ai dés-installé 9.3 : sudo apt-get purge postgresql-9.3

Comment reprendre la main avec cette nouvelle version 9.6 de postgres ?
L'installation est passée par :  postgresql-9.6.0-1-linux-x64.run

Dernière modification par abuche (05/10/2016 20:18:03)

Hors ligne

#4 05/10/2016 22:26:39

rjuju
Administrateur

Re : [Resolu] Postgres 9.6 - Postgis

Je ne connais pas du tout les installeurs externes pour linux.  Ce n'est que mon avis, mais à votre place j'installerais la 9.6 via les paquets communautaires, comme vous l'aviez fait pour la 9.3. En tout cas mixer les deux est certainement une mauvaise idée.

Hors ligne

#5 05/10/2016 22:54:32

abuche
Membre

Re : [Resolu] Postgres 9.6 - Postgis

Ok je vais trop vite
Je suis parti sur une version entreprise qui s'est installé très facilement

http://www.enterprisedb.com/products-se … load#linux

Mais ensuite psql n'est pas du tout actif

Le lien vient d'un postgres.org

https://www.postgresql.org/download/linux/ubuntu/

Pouvez vous donner un lien vers une installation qui ne posera pas ce problème ?

@+

Dernière modification par abuche (05/10/2016 22:59:02)

Hors ligne

#6 06/10/2016 07:10:17

rjuju
Administrateur

Re : [Resolu] Postgres 9.6 - Postgis

Hors ligne

#7 06/10/2016 10:29:56

abuche
Membre

Re : [Resolu] Postgres 9.6 - Postgis

Quickstart

Create /etc/apt/sources.list.d/pgdg.list. The distributions are called codename-pgdg. In the example, replace wheezy with the actual distribution you are using:

deb http://apt.postgresql.org/pub/repos/apt/ wheezy-pgdg main
---------------------------------------------------------------------------------
deb : commande introuvable , n'est pas supporté par ubuntu
---------------------------------------------------------------------------------

Le postgres que j'ai effacé communiquait mal avec postgis
Je veux éviter des installations mal embarquées

Dernière modification par abuche (06/10/2016 10:33:45)

Hors ligne

#8 06/10/2016 13:45:33

gleu
Administrateur

Re : [Resolu] Postgres 9.6 - Postgis

deb n'est pas une commande. La ligne deb doit être ajoutée dans le fichier pgdg.list.

Hors ligne

#9 06/10/2016 14:46:27

abuche
Membre

Re : [Resolu] Postgres 9.6 - Postgis

gleu : ok merci, j'ai obtenu cette installation de 9.5

Comment je peux trouver la bonne extension de postgis ?

[resolu]

Dernière modification par abuche (06/10/2016 17:37:55)

Hors ligne

Pied de page des forums