PostgreSQL La base de donnees la plus sophistiquee au monde.

Forums PostgreSQL.fr

Le forum officiel de la communauté francophone de PostgreSQL

Vous n'êtes pas identifié(e).

#1 03/01/2013 17:01:38

barthymus
Membre

Incompatibilité 9.2 et PhpPgAdmin 5.0.4

Bonjour,

J'ai installé récemment phpPgAdmin 5.0.4 sur un serveur lié à des bases PG 9.2.1.
Le soucis est qu'apparament, les développeurs ont supprimer une colonne 'spclocation' ce qui provoque quelques soucis dans phpPgAdmin :

 Erreur SQL :

ERROR:  column "procpid" does not exist
LINE 3:     WHERE datname='base1' ORDER BY usename, procpid
                                                    ^
Dans l'instruction :

				SELECT * FROM pg_catalog.pg_stat_activity
				WHERE datname='base1' ORDER BY usename, procpid 

et

 
Erreur SQL :

ERROR:  column "spclocation" does not exist
LINE 1: ...pg_catalog.pg_get_userbyid(spcowner) AS spcowner, spclocatio...
                                                             ^
Dans l'instruction :

SELECT spcname, pg_catalog.pg_get_userbyid(spcowner) AS spcowner, spclocation,
                    (SELECT description FROM pg_catalog.pg_shdescription pd WHERE pg_tablespace.oid=pd.objoid) AS spccomment
					FROM pg_catalog.pg_tablespace WHERE spcname NOT LIKE $$pg\_%$$ ORDER BY spcname

J'ai rien trouvé de vraiment concluant dessus. Je voulais savoir si vous aviez ce problème sur vos propres configurations ?

Merci ! smile

Hors ligne

#2 03/01/2013 18:11:47

gleu
Administrateur

Re : Incompatibilité 9.2 et PhpPgAdmin 5.0.4

En 9.2, procpid a été renommé en pid par soucis de cohérence avec une autre vue système. Quant à spclocation, elle a disparu, remplacé par une fonction système.

À ma connaissance, phpPgAdmin a été corrigé mais aucune version officielle n'est sortie depuis cette correction (oui, comme check_postgres). Le mieux là-aussi est d'utiliser le code disponible dans le dépôt git.

Hors ligne

#3 20/09/2016 11:56:09

will
Membre

Re : Incompatibilité 9.2 et PhpPgAdmin 5.0.4

Bonjour,

J'ai le même souci avec PhpPgadmin 4.2.3 connecté sur un serveur ou coexistent 2 versions de postgresql : 8.3.23 et 9.5.1 (je précise que la version 9.5 correspond à un upgrade de la version 8.3)

Bizarrement, impossible de rajouter des contraintes sur mes tables de la version 9.5 alors que cela fonctionne sur la version 8.3 ...

Une solution possible ?

Merci bien !

Wilfried

Dernière modification par will (20/09/2016 11:57:33)

Hors ligne

#4 20/09/2016 13:56:59

gleu
Administrateur

Re : Incompatibilité 9.2 et PhpPgAdmin 5.0.4

Vous ne pouvez pas utiliser phpPgAdmin 4.2.3 avec un PostgreSQL 9.5. Mettez à jour phpPgAdmin.

Hors ligne

Pied de page des forums