PostgreSQL La base de donnees la plus sophistiquee au monde.

Forums PostgreSQL.fr

Le forum officiel de la communauté francophone de PostgreSQL

Vous n'êtes pas identifié(e).

#1 15/12/2016 11:30:00

romaric
Membre

probleme de connection avec psql sur linux

Bonjour
j'ai installé postgresql 9.4 ou 9.6. et les clients "postgresql-client-common  et  postgres-xc-client" .
Mais lorsque j'essai de me connecter sur l'invite de commande psql j'obtiens cette erreur:   "psql: could not connect to server: Connexion refusée
    Is the server running locally and accepting
    connections on Unix domain socket "/var/run/postgresql/.s.PGSQL.5432"?

j'aimerais avoir une solution car je suis bloqué et je ne peux plus continuer mes recherches.
merci

Dernière modification par romaric (15/12/2016 11:31:55)

Hors ligne

#2 15/12/2016 11:47:27

ruizsebastien
Membre

Re : probleme de connection avec psql sur linux

Bonjour,

Dans ton postgresql.conf : quel est la valeur du parametre "listen_addresses" (doit être positionné à listen_addresses = '*').
Peux-tu nous donner le contenu de ton pg_hba.conf.

L'instance est-elle démarrée (donne la liste retournée par "ps -ef |grep postgres")

Hors ligne

#3 15/12/2016 13:42:12

romaric
Membre

Re : probleme de connection avec psql sur linux

bonjour sebastien
j'ai verifié mon listen_addresses et il est positionné à listen_addresses = '*'.


le contenu du fichier pg_hba.conf est ceci:

# PostgreSQL Client Authentication Configuration File
# ===================================================
#
# Refer to the "Client Authentication" section in the PostgreSQL
# documentation for a complete description of this file.  A short
# synopsis follows.
#
# This file controls: which hosts are allowed to connect, how clients
# are authenticated, which PostgreSQL user names they can use, which
# databases they can access.  Records take one of these forms:
#
# local      DATABASE  USER  METHOD  [OPTIONS]
# host       DATABASE  USER  ADDRESS  METHOD  [OPTIONS]
# hostssl    DATABASE  USER  ADDRESS  METHOD  [OPTIONS]
# hostnossl  DATABASE  USER  ADDRESS  METHOD  [OPTIONS]
#
# (The uppercase items must be replaced by actual values.)
#
# The first field is the connection type: "local" is a Unix-domain
# socket, "host" is either a plain or SSL-encrypted TCP/IP socket,
# "hostssl" is an SSL-encrypted TCP/IP socket, and "hostnossl" is a
# plain TCP/IP socket.
#
# DATABASE can be "all", "sameuser", "samerole", "replication", a
# database name, or a comma-separated list thereof. The "all"
# keyword does not match "replication". Access to replication
# must be enabled in a separate record (see example below).
#
# USER can be "all", a user name, a group name prefixed with "+", or a
# comma-separated list thereof.  In both the DATABASE and USER fields
# you can also write a file name prefixed with "@" to include names
# from a separate file.
#
# ADDRESS specifies the set of hosts the record matches.  It can be a
# host name, or it is made up of an IP address and a CIDR mask that is
# an integer (between 0 and 32 (IPv4) or 128 (IPv6) inclusive) that
# specifies the number of significant bits in the mask.  A host name
# that starts with a dot (.) matches a suffix of the actual host name.
# Alternatively, you can write an IP address and netmask in separate
# columns to specify the set of hosts.  Instead of a CIDR-address, you
# can write "samehost" to match any of the server's own IP addresses,
# or "samenet" to match any address in any subnet that the server is
# directly connected to.
#
# METHOD can be "trust", "reject", "md5", "password", "gss", "sspi",
# "ident", "peer", "pam", "ldap", "radius" or "cert".  Note that
# "password" sends passwords in clear text; "md5" is preferred since
# it sends encrypted passwords.
#
# OPTIONS are a set of options for the authentication in the format
# NAME=VALUE.  The available options depend on the different
# authentication methods -- refer to the "Client Authentication"
# section in the documentation for a list of which options are
# available for which authentication methods.
#
# Database and user names containing spaces, commas, quotes and other
# special characters must be quoted.  Quoting one of the keywords
# "all", "sameuser", "samerole" or "replication" makes the name lose
# its special character, and just match a database or username with
# that name.
#
# This file is read on server startup and when the postmaster receives
# a SIGHUP signal.  If you edit the file on a running system, you have
# to SIGHUP the postmaster for the changes to take effect.  You can
# use "pg_ctl reload" to do that.

# Put your actual configuration here
# ----------------------------------
#
# If you want to allow non-local connections, you need to add more
# "host" records.  In that case you will also need to make PostgreSQL
# listen on a non-local interface via the listen_addresses
# configuration parameter, or via the -i or -h command line switches.



# TYPE  DATABASE        USER            ADDRESS                 METHOD

# "local" is for Unix domain socket connections only
local   all             all                                     md5
# IPv4 local connections:
host    all             all             127.0.0.1/32            md5
# IPv6 local connections:
host    all             all             ::1/128                 md5
# Allow replication connections from localhost, by a user with the
# replication privilege.
#local   replication     postgres                                md5
#host    replication     postgres        127.0.0.1/32            md5
#host    replication     postgres        ::1/128                 md5




et voici le resultat de la commande ps -ef | grep postgres:


root@romaric-box:/opt/PostgreSQL/9.4/data# ps -ef | grep postgres
postgres  1463     1  0 12:14 ?        00:00:00 /opt/PostgreSQL/9.4/bin/postgres -D /opt/PostgreSQL/9.4/data
postgres  1464  1463  0 12:14 ?        00:00:00 postgres: logger process                                   
postgres  1467  1463  0 12:14 ?        00:00:00 postgres: checkpointer process                             
postgres  1468  1463  0 12:14 ?        00:00:00 postgres: writer process                                   
postgres  1469  1463  0 12:14 ?        00:00:00 postgres: wal writer process                               
postgres  1470  1463  0 12:14 ?        00:00:00 postgres: autovacuum launcher process                       
postgres  1471  1463  0 12:14 ?        00:00:00 postgres: stats collector process                           
root      3920  3856  0 12:39 pts/0    00:00:00 grep --color=auto postgres
root@romaric-box:/opt/PostgreSQL/9.4/data#


merci d'avance.

Hors ligne

#4 15/12/2016 14:00:05

ruizsebastien
Membre

Re : probleme de connection avec psql sur linux

si tu essaies de te connecter à distance (depuis un pc client par exemple) ce n'est pas possible à cause de ton pg_hba.conf.

Essaie de modifier le pg_hba.conf comme ceci par exemple (et relance l'instance postgresql) :
(remplacer toutes les lignes par celles-ci)
#connexion socket unix :
local   all         all                                      md5
#connexion TCP/IP ipv4 :
host    all         all         0.0.0.0         0.0.0.0          md5
#connexion TCP/IP ipv6 :
host    all         all               ::1/128                md5

Hors ligne

#5 15/12/2016 16:00:20

romaric
Membre

Re : probleme de connection avec psql sur linux

je viens de faire ce que vous m'avez dit mais le même problème est  présent.

je réfléchis d'autre alternative en attendant certaines de vos propositions.
merci

Hors ligne

#6 15/12/2016 16:04:53

ruizsebastien
Membre

Re : probleme de connection avec psql sur linux

tu fais une connexion distante ou locale ?

Après avoir modifier le pg_hba.conf as-tu relancé l'instance ?

(Rappel : il faut que ce soit le pg_hba.conf du serveur.)
le port est-il 5432 pour ton instance ?
quel est la commande passée pour te connecter ?

Dernière modification par ruizsebastien (15/12/2016 16:07:23)

Hors ligne

#7 15/12/2016 22:06:20

rjuju
Administrateur

Re : probleme de connection avec psql sur linux

romaric a écrit :

Bonjour
j'ai installé postgresql 9.4 ou 9.6. et les clients "postgresql-client-common  et  postgres-xc-client" .
Mais lorsque j'essai de me connecter sur l'invite de commande psql j'obtiens cette erreur:   "psql: could not connect to server: Connexion refusée
    Is the server running locally and accepting
    connections on Unix domain socket "/var/run/postgresql/.s.PGSQL.5432"?

j'aimerais avoir une solution car je suis bloqué et je ne peux plus continuer mes recherches.
merci

Le message indique qu'il s'agit d'une tentative de connexion par socket unix. Vérifier le listen_adresses n'aidera pas.  Pouvez-vous nous donner le contenu de /var/run/postgresql, ainsi que la valeur de unix_socket_directory ou unix_socket_directories selon la version ? (ainsi que le port comme demandé par Sébastien).

Pouvez-vous sinon essayer de vous connecter via une socket IP (psql -h 127.0.0.1)

Hors ligne

#8 21/12/2016 10:37:23

romaric
Membre

Re : probleme de connection avec psql sur linux

Bonjour rjuju

le chemin /var/run/postgresql n'existe pas sur ma machine.
le chemin qui s' y trouve est   /var/run/    il n'y a pas de repertoire postgresql dans le /run.
quel est la commande que je dois saisir pour avoir le contenu de unix_socket_directory
merci

Hors ligne

#9 21/12/2016 10:42:15

gleu
Administrateur

Re : probleme de connection avec psql sur linux

Le plus simple est de lancer "postgres -D /répertoire_des_donnees -C unix_socket_directory" (ou unix_socket_directories suivant la version).

Hors ligne

Pied de page des forums