PostgreSQL La base de donnees la plus sophistiquee au monde.

Forums PostgreSQL.fr

Le forum officiel de la communauté francophone de PostgreSQL

Vous n'êtes pas identifié(e).

#1 29/10/2016 23:01:14

zendeine
Membre

message d'erreur dans la création de la base

salut a tous

message d'erreur dans la création de la base
Server doesn't listen
The server doesn't accept connections: the connection library reports
could not connect to server: Connection refused (0x0000274D/10061) Is the server running on host "localhost" (::1) and accepting TCP/IP connections on port 5432? could not connect to server: Connection refused (0x0000274D/10061) Is the server running on host "localhost" (127.0.0.1) and accepting TCP/IP connections on port 5432?
If you encounter this message, please check if the server you're trying to contact is actually running PostgreSQL on the given port. Test if you have network connectivity from your client to the server host using ping or equivalent tools. Is your network / VPN / SSH tunnel / firewall configured correctly?
For security reasons, PostgreSQL does not listen on all available IP addresses on the server machine initially. In order to access the server over the network, you need to enable listening on the address first.
For PostgreSQL servers starting with version 8.0, this is controlled using the "listen_addresses" parameter in the postgresql.conf file. Here, you can enter a list of IP addresses the server should listen on, or simply use '*' to listen on all available IP addresses. For earlier servers (Version 7.3 or 7.4), you'll need to set the "tcpip_socket" parameter to 'true'.
You can use the postgresql.conf editor that is built into pgAdmin III to edit the postgresql.conf configuration file. After changing this file, you need to restart the server process to make the setting effective.
If you double-checked your configuration but still get this error message, it's still unlikely that you encounter a fatal PostgreSQL misbehaviour. You probably have some low level network connectivity problems (e.g. firewall configuration). Please check this thoroughly before reporting a bug to the PostgreSQL community.

Hors ligne

#2 30/10/2016 08:22:52

rjuju
Administrateur

Re : message d'erreur dans la création de la base

Un peu plus de détail ? Vous avez ce message lors de la création d'une base alors que vous avez pu vous connecter ?

En ligne

#3 30/10/2016 21:27:25

zendeine
Membre

Re : message d'erreur dans la création de la base

salut de nouveau

oui après un clic sur le bouton "ajouter une connexion a un serveur" puis donnée un nom au base de donnée  jusqu'au ..nom d'utilisateur et le mot de passe  je reçois en premier un message "Saving passwords
WARNING: You have opted to save your password. It will be stored in plain text in your home directory on *nix systems, or in your user profile on Windows. If you do not want this to happen, please press the Cancel button.
pgAdmin uses PostgreSQL's 'pgpass' mechanism to store your passwords. On *nix systems, the password will be stored in ~/.pgpass, whilst on Windows systems it will be stored in %APPDATA%\PostgreSQL\pgpass.conf (%APPDATA% is the 'Application Data' folder in your user profile). This mechanism is used by default by all programs that use the libpq library to access the server, which includes command line applications such as pg_dump and pg_restore, other GUI applications, and drivers such as psqlODBC. This means that those applications may automatically connect to the server using your stored password. If you do not want this to happen, you should not use the Store Password option in pgAdmin. "
puis un 2eme message deja cité la haut
et merci d'avance

Hors ligne

#4 31/10/2016 10:12:08

rjuju
Administrateur

Re : message d'erreur dans la création de la base

Et bien le message d'erreur vous donne la raison : « The server doesn't accept connections »


Avez-vous vérifié ce qui est expliqué dans la suite du message d'erreur ? (« Is the server running on host "localhost" (::1) and accepting TCP/IP connections on port 5432? » et tout le reste).

En ligne

#5 31/10/2016 23:24:11

zendeine
Membre

Re : message d'erreur dans la création de la base

merci pour la repense :alors je dois changer dans la Hote et mettre quoi?  ou bien dans le port tcp et mettre 127.0.0.1 au lieu de 5432

Hors ligne

Pied de page des forums