PostgreSQL La base de donnees la plus sophistiquee au monde.

Forums PostgreSQL.fr

Le forum officiel de la communauté francophone de PostgreSQL

Vous n'êtes pas identifié(e).

#1 05/09/2011 10:57:40

lebrunnya
Membre

PROBLEME ODBC VIA QLIKVIEW et DBLINK

Bonjour,

Pour avoir accès aux données des tables de ma base de données PostgreSQL via un programme externe (Qlikview), J'ai installé la librairie dblink sur cette base de données.
Lorsque j'accède via Qlikview à cette base de données, je n'arrive pas à avoir les données des tables.

Le pilote odbc pour postgreSQL est bien installé sur le poste à partir duquel Qlikview fonctionne et le user que j'utilise à tous les droits.

A partir de Qlikview, j'arrive a voir la structure de la table (les différents champs avec leurs types), Mais pas les données de la table.

DBLINK est bien installé sur la base de données que j’interroge.

Je suis bloqué depuis deux jours déjà et j'aimerais pouvoir solutionné le problème.

Quelqu'un aurait'il déjà eu le même problème ou tout simplement me guider pour trouver la solution a mon problème ?

Merci d'avance,
Lebrun Nya

Hors ligne

#2 05/09/2011 15:45:23

gleu
Administrateur

Re : PROBLEME ODBC VIA QLIKVIEW et DBLINK

Sans message d'erreur, sans explication plus précise, je ne vois pas comment on pourrait vous aider.

Hors ligne

#3 03/11/2011 17:03:54

emar
Membre

Re : PROBLEME ODBC VIA QLIKVIEW et DBLINK

Symptomes identiques entre qlikview et une base postgreSQL avec un connexion via pilote ODBC.

Le pilote est installé correctement. Via l'interface qlikview, la connexion à la base de données fonctionne, la liste des tables et des colonnes des tables est accessible. Par contre, impossible de reqûeter les données :

Le message d'erreur est le suivant :

SQL##f - SqlState: 0A000, ErrorCode: 7, ErrorMsg: ERROR: cross-database references are not implemented

Pourtant la requête mise en oeuvre est mono-base, mono-schéma.

J'ai installé et testé avec plusieurs versions du driver (v8.04 et v9.00) mais aucune différence.

Je n'ai pas de contournement pour traiter le sujet et suis donc coincé. Quelqu'un aurait une idée ?

Emmanuel

Hors ligne

#4 03/11/2011 17:22:22

gleu
Administrateur

Re : PROBLEME ODBC VIA QLIKVIEW et DBLINK

Apparemment, qlikview essaie d'exécuter une requête qui n'est pas acceptée par PostgreSQL. Le mieux est certainement de se tourner vers les développeurs de qlikview pour savoir ce qu'il se passe.

Hors ligne

#5 03/11/2011 17:30:44

emar
Membre

Re : PROBLEME ODBC VIA QLIKVIEW et DBLINK

C'est bizarre. La plus simple des requêtes : select * from Nom_BDD.Schema.Nom_table ne passe même pas.

Que chercherait à executer Qlikview ? En tout cas, l'editeur de requête qlikview ne montre pas de requêtes complémentaires créées par Qlikview et à executer.

Ne serait ce pas plutôt le driver qui est en cause étant donné que c'est lui qui gère le lien avec la base de données ?

Emmanuel

Dernière modification par emar (03/11/2011 17:40:06)

Hors ligne

#6 03/11/2011 17:41:43

gleu
Administrateur

Re : PROBLEME ODBC VIA QLIKVIEW et DBLINK

"select * from Nom_BDD.Schema.Nom_table" ne peut pas fonctionner avec PostgreSQL. Une requête s'exécute sur une base seulement. Vous ne pouvez pas accéder à d'autres bases, en dehors de l'ajout de modules comme dblink ou PL/proxy. Faites plutôt un "select * from Schema.Nom_table" en étant connecté sur Nom_BDD.

Hors ligne

#7 03/11/2011 17:50:16

emar
Membre

Re : PROBLEME ODBC VIA QLIKVIEW et DBLINK

J'avais bien pensé à ça également mais "select * from Nom_Schema.Nom_table" me retourne SqlState: 3F000, ErrorCode: 7, ErrorMsg: ERROR: schema "Nom_Schema" does not exist. Alors que le nom de schéma a été récupéré automatiquement par l'appli Qlikview et est tout à fait correct.

Pour info, le module dblink est installé sur la base également.

Emmanuel

Hors ligne

#8 03/11/2011 19:08:22

gleu
Administrateur

Re : PROBLEME ODBC VIA QLIKVIEW et DBLINK

Si vous avez des majuscules dans le nom du schéma, vous devez metrre le nom entre guillemets doubles. Et pareil pour la table. Par exemple : select * from "Nom_Schema"."Nom_table"

Hors ligne

#9 03/11/2011 19:14:00

emar
Membre

Re : PROBLEME ODBC VIA QLIKVIEW et DBLINK

C'était en effet le problème, le nom de la table est par défaut entre guillemets quand généré par l'assistant de création de requête qlikview mais pas le nom de schéma. En retouchant la requête pour venir placer le nom de schéma entre guillemet (car en majsucule) plus de problème.

Merci pour le dépannage.

Emmanuel

Hors ligne

Pied de page des forums